You should consider joining our Discord to ask for support.

We created a support channel using the new Discord Forum feature!

You can also visit our new website, it has a help section in English and French

0 like 0 dislike
184 views
in Script help by (190 points)

Voici le soucis , la transparence ne s'ajuste pas en jeu  quand  le " water shader " est utilisé ( c'est censé redevenir opaque , mais la , c'est pas le cas ( donc ça rends le tout sombre vu que  le " void" de base est noir )  ett egalement il est impossible d'avoir le second type d'au avec le dit shader ( comme vidéo d'origine , l'eau en question est celle de la mer ) 

Le rendu en jeu 


voila dans Tiled : 



et dans RMXP : 


et le tileset :



chez moi il est bien tranparent et devrait pas poser de soucis , j'ai aucun panorama ou autre derriere

En gros  j'ai l'impression que le canal alpha ne passe pas DU TOUT a 100% in game ( comme sur la video d'origine encore )

1 Answer

0 like 0 dislike
by (28.0k points)
Il faut juste mettre la propriété .a du fragColor a 1 et la transparence disparaitra.
by (190 points)
alors .... ou exactement ?  j'suis pas sur de comprendre , et puis , ça aide pas pour le choix de type d'eau ? si ? ( que j'ai aussi mentionné ;) )
by (28.0k points)
Ca se fait dans le fichier shader (graphics/shader/nom du shader.frag)

Pour le choix ça dépend de la transparence que tu as appliqué sur ton tileset.
by (190 points)
j'ai regardé , et justement , je vois pas d'option a changer la dedans ,  la seule mention d'une proprieté qui pourrait correspondre  dans dans une grand condition " if "  et la condition en question est deja censée rendre la valeur a 1  ( ou alors je vois pas du tout la ligne en question )

quand aux choix , j'ai beau  essayer autant ver le 10% que le 90% ( et des paier entre )  ça n'a pas bougé
...